logo  
 
Translation :
 
   
 
Menu général :
 
   
 
Espace Membre :
 
 
Privé Se connecter


Se souvenir de moi ?


Mot de passe oublié

 
 
Liens Web :
 
   
 
Forum : Masquer l’entête
 
 
Accès rapide :

Effectuer une Recherche avancée OU


 
 
[Résolu] Dépassement volume d'heures composante  [9 réponses]
 
 


 
 
 
 
 
 
 
 
 
fperciot
starsj1.png
Newbie


avatar
Hors ligne

Nombre de posts: 21
Inscrit(e) le: 08 septembre 2016
Imprimer dimanche 16 avril 2017 à 20:26  

Bonjour Sylvain,
Tout d'abord, bonne Pâques.
J'ai testé la version 2017-04-12 que tu as mis à disposition de Bastien dans le post [url=violation d'accès - vt réseau 12/2016 http://visual.timetabling.free.fr/index.php?mod=forum&ac=voir&id=1283[/url]
et je fais face à 3 problèmes.
Les deux premiers concernent les Composantes (Filière -> Composantes) :

(J'ai fait ces tests avec mon login "administrateur qui à tous les droits sur tout")

Lorsque l'on visualise les composantes (voir image ci-dessous) on voit que dans la colonne "Type" on a comme valeur "Autre" alors que sur la droite de l'écran on a bien la bonne valeur, à savoir "Enseignement" (comme je l'ai renseigné initialement)
De plus, lorsque l'on modifie cette valeur (et quelque soit cette valeur, lorsque l'on enregistre) la valeur à droite se retrouve être "Autre" (ceci est confirmé par la valeur "18" que l'on retrouve dans le champs "typeComposante" dans la table "composantes")
Ces 2 problèmes peuvent être facilement contournés en modifiant manuellement les valeurs directement dans la BdD mais je ne vois pas si ce problème vient de la BdD ou bien de VT_Reseau.
image


Le troisième problème concerne l' "ajouter/modifier/détruire" d'enseignement ainsi que le placement de séance.
(j'ai fait ces tests là avec 2 logins :
- une fois avec le login d'une utilisatrice qui a des droits "classiques" et tout se passe bien
- une fois avec mon login "administrateur qui à tous les droits sur tout" et là, j'ai les problèmes qui suivent)

Lorsque je veux faire un ajout d'un enseignement (voir première image ci-dessous), j'ai aussi le même problème lorsque que tente de placer une séance (voir deuxième image ci_dessous), je remplis tous les champs nécessaires avec des valeurs valides (qui viennent de VT lui-même), mais lorsque j'appuie sur "Ajouter, j'ai un message d'erreur : "Le volume total alloué à la composante est dépassé de plus de -1 pourcent. Vous ne pouvez plus ajouter de séances pour cette composante".
Je ne sais pas où est mis le nombre d'heures maxi pour cette composante et je n'ai trouvé aucun endroit où le stipuler.
Avec la version 2016-12-01 que j'ai testé au préalable, je n'ai pas eu ce problème de limite.
Je me demande donc si le problème vient de mes données ou bien de VT lui-même ou encore parce que je ne suis pas propriétaire de ces ressources.

Exemple avec l'ajout d'un enseignement :
image

Exemple avec le placement d'une séance :
image

Comme nous sommes en train de travailler sur la fourniture à nos utilisateurs de la base pour préparer 2017/2018 en voulant nous mettre à jour avec la dernière version de VT fournie par Sylvain, nous sommes un peu dans la panade.
Merci d'avance pour ton aide,
Bien cordialement,
Florent P.

P.S.: Je peux mettre à disposition notre BdD en MP pour aider au débugage.
P.S.S.: J'avais soumis un problème dans le post suivant: [url=Version beta du 09/01/17 Lien ICI[/url] et j'aurais voulu savoir si tu avais pu y jeter un coup d'oeil




 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien dimanche 23 avril 2017 à 19:40  

Bonjour Florent,

Je suis actuellement en déplacement et je n'ai pas à disposition tous mes outils de travail pour t'aider.
Je regarderai tes pbs à mon retour en fin de semaine.

J'espère que tu as passé un bon week-end de Pâques

Sylvain




Bonjour Florent,

Je peux maintenant te répondre :


Citation de fperciot :
Lorsque l'on visualise les composantes (voir image ci-dessous) on voit que dans la colonne "Type" on a comme valeur "Autre" alors que sur la droite de l'écran on a bien la bonne valeur, à savoir "Enseignement" (comme je l'ai renseigné initialement)
De plus, lorsque l'on modifie cette valeur (et quelque soit cette valeur, lorsque l'on enregistre) la valeur à droite se retrouve être "Autre" (ceci est confirmé par la valeur "18" que l'on retrouve dans le champs "typeComposante" dans la table "composantes")
Ces 2 problèmes peuvent être facilement contournés en modifiant manuellement les valeurs directement dans la BdD mais je ne vois pas si ce problème vient de la BdD ou bien de VT_Reseau.
image



C'est un bug que j'ai corrigé.



Citation de fperciot :
Le troisième problème concerne l' "ajouter/modifier/détruire" d'enseignement ainsi que le placement de séance.
(j'ai fait ces tests là avec 2 logins :
- une fois avec le login d'une utilisatrice qui a des droits "classiques" et tout se passe bien
- une fois avec mon login "administrateur qui à tous les droits sur tout" et là, j'ai les problèmes qui suivent)

Lorsque je veux faire un ajout d'un enseignement (voir première image ci-dessous), j'ai aussi le même problème lorsque que tente de placer une séance (voir deuxième image ci_dessous), je remplis tous les champs nécessaires avec des valeurs valides (qui viennent de VT lui-même), mais lorsque j'appuie sur "Ajouter, j'ai un message d'erreur : "Le volume total alloué à la composante est dépassé de plus de -1 pourcent. Vous ne pouvez plus ajouter de séances pour cette composante".
Je ne sais pas où est mis le nombre d'heures maxi pour cette composante et je n'ai trouvé aucun endroit où le stipuler.
Avec la version 2016-12-01 que j'ai testé au préalable, je n'ai pas eu ce problème de limite.
Je me demande donc si le problème vient de mes données ou bien de VT lui-même ou encore parce que je ne suis pas propriétaire de ces ressources.



Il n'y a aucun problème !
Lorsque tu définis tes composantes, Filières/composantes/Ajouter-Modifier-Détruire, il y a plusieurs champs qui ont fait leur apparitions :
- le champ directeur : il permet d'indiquer qui est le directeur de la composante (parmi les profs)
- les champs "Volume max FI", "Volume max FC" ect : ils permettent, si on le souhaite, de contrôler que les composantes ne dépassent pas le budget qui leur est alloué. Il faut donc renseigner ces champs pour que ce soit opérationnel.
De plus, il faut indiquer au niveau des droits des utilisateurs :
a) sa composante (le fait de pouvoir associer une composante à un utilisateur est une nouveauté)
b) Alarme 1 : par défaut la valeur est 5 ce qui représente 5%
c) Alarme 2 : par défaut la valeur est 10 ce qui représente 10%
Ainsi si on dépasse de 10% le volume total autorisé pour une composante : VT bloque, si on dépasse de 5% : VT affiche un message. Le volume total autorisé pour une composante est la somme Volume max FI + Volume max FC + ...
Si on dépasse de 5% le volume autorisé, un message est affiché et en plus un mail est envoyé automatiquement à l'utilisateur et au directeur de la composante afin qu'il prenne les mesures nécessaires.
Si on ne veut pas utiliser cette possibilité, il suffit de décocher la commande "Contrôler le volume global des composantes" de la catégorie "Général" des droits "Utilisateur".

Ceci a été mis en place afin d'avoir un meilleur pilotage d'une université.

Je pense que tu as du te donner tous les droits et donc cette case est cochée pour toi.


Citation de fperciot :
P.S.S.: J'avais soumis un problème dans le post suivant: [url=Version beta du 09/01/17 Lien ICI[/url] et j'aurais voulu savoir si tu avais pu y jeter un coup d'oeil



Je pense que ce pb est lié au précédent. Puisque VT constate que tu dépasse : il bloque.
Par contre le message qui apparait n'est pas le bon puisque la séance n'est pas enregistrée.


Sylvain


J'ai déposé les mises à jour de vt_reseau et vt_admin
Édité 4 fois - Dernière édition: 24/04/2017 à 08:29 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
jbr
starsj3.png
Habitué


avatar
Hors ligne

Nombre de posts: 79
Inscrit(e) le: 10 mai 2011
Imprimer Permalien mercredi 26 avril 2017 à 16:27  

Bonjour Sylvain,

En mettant la dernière Beta, nous avons :"mysql error 1054" unknown column 'code composante' in field list.

Cette année je souhaiterai pouvoir filtrer par les composantes en rajoutant des "sous" comosnate, mais dans la version VT du 12/12/2016, je ne peux sélectionner les composantes, le champ reste vide lors de la création/modification d'un enseignement.
y a t il un rapport?

Merci de votre aide



Visiter son site


 
 
 
 
 
 
fperciot
starsj1.png
Newbie


avatar
Hors ligne

Nombre de posts: 21
Inscrit(e) le: 08 septembre 2016
Imprimer Permalien mercredi 26 avril 2017 à 16:59  

Bonjour Sylvain,
Merci pour la correction du "bug" et des explications.
Faute de temps (nos utilisateurs nous pressent ardemment pour avoir à leur disposition la base 2017/201 smiley s8g29g.gif , nous devoir allons utiliser la version du 01/12/2016.
Ceci étant, je vais suivre de manière plus attentive les évolutions de version (et préparer des tests extensifs mais pas dans la précipitation) pour qu'à notre prochaine mise à jour, nous ne soyons pas pris à la gorge comme cela a été le cas cette fois.
En tous cas, merci beaucoup pour tous les efforts que tu déploies pour nous aider.
Cdt,
Florent P.




 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mercredi 26 avril 2017 à 23:42  


Citation de jbr :

Bonjour Sylvain,



Bonjour,


Citation de jbr :
En mettant la dernière Beta, nous avons :"mysql error 1054" unknown column 'code composante' in field list.



A quel moment exactement ?
La stucture de la base a t elle été mise à jour ? C'est indispensable pour utiliser les nouvelles versions.
Le champ codeComposante apparait dans la table utilisateurs : est-ce bien le cas ?


Citation de jbr :
Cette année je souhaiterai pouvoir filtrer par les composantes en rajoutant des "sous" comosnate, mais dans la version VT du 12/12/2016, je ne peux sélectionner les composantes, le champ reste vide lors de la création/modification d'un enseignement.
y a t il un rapport?



Je ne comprends pas la question ?

Sylvain





Citation de fperciot :
Bonjour Sylvain,


Bonjour,

Citation de fperciot :
Merci pour la correction du "bug" et des explications.
Faute de temps (nos utilisateurs nous pressent ardemment pour avoir à leur disposition la base 2017/201 smiley s8g29g.gif , nous devoir allons utiliser la version du 01/12/2016.
Ceci étant, je vais suivre de manière plus attentive les évolutions de version (et préparer des tests extensifs mais pas dans la précipitation) pour qu'à notre prochaine mise à jour, nous ne soyons pas pris à la gorge comme cela a été le cas cette fois.




Citation de fperciot :
En tous cas, merci beaucoup pour tous les efforts que tu déploies pour nous aider.
Cdt,
Florent P.



Pas de soucis ! tu peux compter sur moi !
De notre coté, nous continuons à avancer avec la nouvelle version de VT que je vais mettre en place chez nous pour commencer à préparer la prochaine année universitaire ...

Sylvain
Édité 2 fois - Dernière édition: 26/04/2017 à 23:44 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
jbr
starsj3.png
Habitué


avatar
Hors ligne

Nombre de posts: 79
Inscrit(e) le: 10 mai 2011
Imprimer Permalien mardi 2 mai 2017 à 09:53  

Bonjour,

Dès le démarrage l’erreur, se produit.
Je crois que notre base est à jour à revérifier avec @zoummuoz... à son retour de vacances! fin de semaine prochaine.

Parallèlement pour la deuxième demande.
On arrive pas à sélectionner la composante, donc on ne peut pas créer de nouveau enseignement...
image
Merci de l'attention

Édité 1 fois - Dernière édition: 02/05/2017 à 09:54 Par jbr.



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mardi 2 mai 2017 à 10:09  

Bonjour,

Ca c'est bizarre ...

Es-tu certain d'avoir les droits nécessaires pour accéder aux composantes ?

Sylvain


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
jbr
starsj3.png
Habitué


avatar
Hors ligne

Nombre de posts: 79
Inscrit(e) le: 10 mai 2011
Imprimer Permalien mardi 2 mai 2017 à 18:08  

Merci de la réponse rapide, oui j'ai tous les droits...

J'ai même pu créer de nouvelle composante, j'ai voulu repartir sur une base vierge.. et au dernier moment j'ai réimporte les enseignements pour plus de rapidité.



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mercredi 3 mai 2017 à 09:45  

Bonjour,

Il faudrait vérifier qui est le propriétaire des composantes et t'assurer que tu as bien les droits sur les données de cet utilisateur concernant les composantes.
Ces droits ne sont pas définis au niveau individuel mais au niveau des groupes d'utilisateurs.

C'est la seule explication que je peux donner.

Sylvain

PS si tu le souhaites, envoies moi une copie de ta abse et j'y regarderai.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
jbr
starsj3.png
Habitué


avatar
Hors ligne

Nombre de posts: 79
Inscrit(e) le: 10 mai 2011
Imprimer Permalien vendredi 7 juillet 2017 à 15:50  

Bonjour Sylvain,

Je n'arrive pas à ces accès avec la dernière version VT admin


Citation :

Si on ne veut pas utiliser cette possibilité, il suffit de décocher la commande "Contrôler le volume global des composantes" de la catégorie "Général" des droits "Utilisateur".



"Comment faire le volume totale de la composante est dépassé de plus de -1 pour cent"

Merci


OUPS TROUVE
Édité 2 fois - Dernière édition: 07/07/2017 à 15:56 Par jbr.



Visiter son site


 
 
 
 
[Résolu] Dépassement volume d'heures composante  [9 réponses]