logo  
 
Translation :
 
   
 
Menu général :
 
   
 
Espace Membre :
 
 
Privé Se connecter


Se souvenir de moi ?


Mot de passe oublié

 
 
Liens Web :
 
   
 
Forum : Masquer l’entête
 
 
Accès rapide :

Effectuer une Recherche avancée OU


 
 
pb version du 27/06/2017  [18 réponses]
 
 


 
 
 
 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1346
Inscrit(e) le: 1er janvier 2008
Imprimer mercredi 28 juin 2017 à 19:29  

Bonjour Sylvain
Je viens de faire les modifs pour faire fonctionner la dernière version mais ça ne marche pas.
Après avoir mis mon login et mon mot de passe, j'obtiens : " n'est pas une valeur entière correcte

J'ai aussi remarqué ceci :
Pour la version du mois de mai, il y avait :
alter table `diplomes` add `typePublic` tinyint(1) NOT NULL DEFAULT '1';

Pour la dernière version :
alter table `diplomes` add `public` tinyint(1) NOT NULL DEFAULT '1';

Est ce un nouveau champ par rapport à la version du mois de mai ou est ce une erreur de ta part ?

Pour info, la version que j'ai testé a été récupérée ici : visual.timetabling.free.fr/MISES-A-JOUR/vt_reseau.exe


Bonne soirée
Bruno



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien jeudi 29 juin 2017 à 09:17  

Bonjour Bruno,


Citation de million :

Je viens de faire les modifs pour faire fonctionner la dernière version mais ça ne marche pas.
Après avoir mis mon login et mon mot de passe, j'obtiens : " n'est pas une valeur entière correcte



Bizarre, aurais-je oublié une modif à faire dans la structure ?
Peux-tu m'envoyer une copie de ta base ?


Citation de million :
J'ai aussi remarqué ceci :
Pour la version du mois de mai, il y avait :
alter table `diplomes` add `typePublic` tinyint(1) NOT NULL DEFAULT '1';

Pour la dernière version :
alter table `diplomes` add `public` tinyint(1) NOT NULL DEFAULT '1';

Est ce un nouveau champ par rapport à la version du mois de mai ou est ce une erreur de ta part ?


Oups , tu as raison ... vivement les vacances !


Citation de million :
Pour info, la version que j'ai testé a été récupérée ici : visual.timetabling.free.fr/MISES-A-JOUR/vt_reseau.exe


C'est la bonne.

Tu devrais y trouver ton bonheur pour la gestion des absences des étudiants (à partir des plannings) car maintenant VT distingue les absences "normales", les retard et les exclusions comme tu me l'avais suggérer.

Sylvain
Édité 3 fois - Dernière édition: 29/06/2017 à 09:19 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1346
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien lundi 3 juillet 2017 à 18:16  

Bonjour
Je n'ai pas la possibilité pour l'instant de t'envoyer la base. Je te la transmettrai lundi.
Bonne journée
Bruno




Bonjour sylvain
Je viens de t'envoyer une copie de ma base par email.
Merci d'avance
Bonne soirée
Bruno



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mardi 4 juillet 2017 à 09:31  

Bonjour Bruno,

J'ai bien reçu ta base.
Le pb vient de ce que ton champ codeDiplome de ta table enseignements vaut NULL.
Il te suffit de remplacer tout cela par 0.

Il me semblait que c'était la valeur par défaut que j'avais mis.

Pour assurer le coup et éviter que cela ne se reproduise, je pense que je vais revoir toutes mes requêtes et tester la présence ou non de valeurs lorsqu'elles sont obligatoires.
Il y aura double contrôle mais au moins ca évitera d'autres désagréments.

Tiens nous au courant ... smiley sg3agg29g.gif

Sylvain


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1346
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien mardi 4 juillet 2017 à 19:09  

Bonjour
Je viens de faire les modifs et maintenant, c'est ok. Merci !!!

J'ai remarqué un petit bug : dans enseignements/ajouter modifier détruire/tous/ onglet ressource par défaut. Les menus déroulants "types salles", "type matériel" et "zone" sont très petits malgré un init param.

Bonne soirée
Bruno



Visiter son site


 
 
 
 
 
 
CCRI
starsj2.png
Visiteur


avatar
Hors ligne

Nombre de posts: 27
Inscrit(e) le: 04 février 2016
Imprimer Permalien mardi 4 juillet 2017 à 22:45  

Bonsoir Bruno, Bonsoir Sylvain,

Olivier et moi venons de mettre à jour notre base de test.
Lorsque l'on se connecte, on obtient :

image

puis :

image

Aurait-on mal fait la mise à jour ?

Merci.

Bonne soirée.


Olivier et Benoît
IUT Orsay



 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mercredi 5 juillet 2017 à 07:52  

Bonjour,

et avec un initParam ?

VT lit le fichier VT.ini en particulier pour obtenir les parametres d'accès à la base.
Le 1er message indique que le fichier VT.ini est accessible sinon il y aurait eu un message indiquant que la base est inaccessible.
J'écarte donc l'hypothèse de l'absence de VT.ini.

Que se passe t il ensuite ??? VT fonctionne t il ?




Pour Bruno : ok j'ai vu le pb d'affichage et c'est corrigé.
Je vais déposer la maj dès que possible


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
CCRI
starsj2.png
Visiteur


avatar
Hors ligne

Nombre de posts: 27
Inscrit(e) le: 04 février 2016
Imprimer Permalien mercredi 5 juillet 2017 à 08:19  

Bonjour Sylvain,

Nous venons de réessayer ce matin, il n'y a plus d'erreur.
À la place du message d'erreur, on obtient la fenêtre habituelle :

"Message important"
Vous utilisez la version (2017-06-27) de VisualTimetabling

Cette fenêtre va t'elle chercher des données distantes ?

Merci à toi.

Bonne journée.


Olivier et Benoît
IUT Orsay



 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1346
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien mercredi 5 juillet 2017 à 09:01  

Bonjour Sylvain
Je viens de rencontrer un problème avec VT_admin.
J'ai par exemple 2 utilisateurs qui ont le même code propriétaire. Quand j'essaye de supprimer un de ces 2 utilisateurs, vt admin m'en empêche à cause des nouvelles contraintes entre les tables car cet utilisateur possède encore des données.
Comment peut-on faire ?
Bruno



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1576
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien mercredi 5 juillet 2017 à 09:09  

Bonjour Bruno,

Les codes propriétaires devraient tous être différents.
Les synchronisations qui se font à intervalles réguliers se basent sur ces codes et sur les dates de modification.
Si 2 utilisateurs ont le même code propriétaire, il est pratiquement certain que les rafraichissements ne se font pas bien ce qui entraine la création de conflits.

Pour résoudre ton problème, le plus simple est d'aller changer en dur dans la table des utilisateurs le code propriétaire d'un de tes 2 utilisateurs.

Je vais faire le nécessaire pour que ces codes proprietaires soient entièrement sous le contrôle de VT et ainsi interdire l'utilisation du même code pour 2 utilisateurs.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1346
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien mercredi 5 juillet 2017 à 09:31  

J'ai des comptes avec le même code proprietaire (mais pas le même code utilisateur) car j'ai par exemple 2 profs qui font les emplois du temps d'une même formation. Je leur ai donc créé un compte chacun.
Il y a aussi parfois un compte pour le secrétariat d'une formation et un compte pour la personne qui fait les emploi du temps. Ils ont le même code proprietaire mais pas les mêmes droits. Si tu interdis à 2 utilisateurs d'avoir le même code proprietaire, je ne peux plus avoir un secretariat et un prof avec des droits différents.



Visiter son site


 
 
 
 
pb version du 27/06/2017  [18 réponses]