logo  
 
Translation :
 
   
 
Menu général :
 
   
 
Espace Membre :
 
 
Privé Se connecter


Se souvenir de moi ?


Mot de passe oublié

 
 
Liens Web :
 
   
 
Forum : Masquer l’entête
 
 
Accès rapide :

Effectuer une Recherche avancée OU


 
 
[Résolu] Problème de hiérarchie des groupes, suite à une ac  [1 réponse]
 
 


 
 
 
 
 
 
 
 
 
CCRI
starsj4.png
Posteur fou


avatar
Hors ligne

Nombre de posts: 163
Inscrit(e) le: 04 février 2016
Imprimer vendredi 23 septembre 2022 à 12:45  

Bonjour Sylvain, Bonjour à toutes et tous,

Nous avons constaté un problème avec 'vt_admin'.
Les étudiants importés par un collègue responsable d'année du département Mesures Physiques, n'étaient pas visibles par les autres collègues du département.

En regardant dans 'vt_admin', nous nous sommes aperçus que son compte 'vt' n'était dans le bon groupe utilisateur.
Nous avons ajouté son compte dans le groupe 'MP_edt' et nous avons sauvegardé.

À partir de ce moment, l'arborescence des groupes du département n'apparaît plus correctement.
Toutes les informations sont encore dans la base de données.
À priori, cela concerne la table 'utilisateurs_appartenances_groupes'.

Nous avons restauré la table 'utilisateurs_appartenances_groupes' (version juste avant de faire la manipulation sur vt_admin) et l'arborescence des groupes est à nouveau fonctionnelle.

Pour information, voici l'arborescence des groupes avant d'utiliser la commande sur vt_admin

image

La capture d'écran de vt_admin, juste avant d'ajouter le compte du collègue dans le groupe MP_edt

image

La capture d'écran de l'arborescence des groupes, une fois la modification faite dans vt_admin

image

Peut-on t'envoyer une copie de notre base de données ?

Merci beaucoup et bonne journée.

Édité 1 fois - Dernière édition: 23/09/2022 à 12:46 Par CCRI.


Olivier et Benoît
IUT Orsay



 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1985
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien vendredi 23 septembre 2022 à 16:40  

Bonjour Olivier et Benoit,

Oui, envoyez-moi une copie de votre base et indiquez-moi précisément ce que je dois faire pour observer le pb.

J'ai l'impression que le propriétaire du groupe MP n'est pas dans le bon groupe d'utilisateurs.
Soit il n'est dans aucun groupe d'utilisateurs soit il est dans un groupe d'utilisateur sur lequel les autres utilisateurs n'ont pas accès.
Ce qui est curieux c'est que le groupe MP n'apparait plus après le changement : c'est pour cela que ses descendants n’apparaissent donc plus comme tel dans les vues.

Sylvain

Édité 2 fois - Dernière édition: 23/09/2022 à 16:52 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
[Résolu] Problème de hiérarchie des groupes, suite à une ac  [1 réponse]