logo  
 
Translation :
 
   
 
Menu général :
 
   
 
Espace Membre :
 
 
Privé Se connecter


Se souvenir de moi ?


Mot de passe oublié

 
 
Liens Web :
 
   
 
Forum : Masquer l’entête
 
 
Accès rapide :

Effectuer une Recherche avancée OU


 
 
Quelques bugs à résoudre  [4 réponses]
 
 


 
 
 
 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1503
Inscrit(e) le: 1er janvier 2008
Imprimer mercredi 31 août 2022 à 11:47  

Bonjour Sylvain

Ca y est, la rentrée approche malheureusement :-(
Je viens de tester la dernière version de VT que tu as déposée et j'ai trouvé quelques bugs.
Je remets donc ci-dessous les anciens bugs non corrigés et les nouveaux.

- Enseignements--> ajouter modifier détruire--> onglet "ressource par défaut", il faudrait renommer le "?" par "Pas de filtre" et griser les cases à cocher.

- Dans Enseignements-->Allocation des ressources aux séances d'un enseignement-->onglet "affectation des ressources"--> onglet "Profs", les trois lignes du haut du tableau de répartition des séances et la colonne de droite sont vides. C'est donc un peu compliqué de connaitre les volumes horaires et le nombre de séances affectées à chaque prof.

- Dans Enseignements-->Allocation des ressources aux séances d'un enseignement-->onglet "affectation des ressources"--> onglets "Salles", "Groupes" et "Matériels", la largeur des colonnes "Libellé","date" et "heure" n'est pas modifiable.

- Dans Enseignements-->Allocation des ressources aux enseignements-->onglet "allocation des ressources"--> onglets "Profs","Salles", "Groupes" et "Matériels", la largeur de la colonne enseignement n'est pas modifiable en largeur. C'est un peu dur à lire quand on a des noms un peu longs.

- Dans groupes--> vue hebdo ou annuelle : après avoir activé l'interrupteur, si je clique sur l'intitulé d'une colonne dans la zone "nb sénaces à placer, la liste des enseignements où il reste des séances à placer se trie bien dans le bon ordre. Ensuite, je place une séances et dès que j'ai placé la séance, VT affiche de nouveau la liste avec le tri initial. Je suis obligé de recliquer sur l'intitulé de la colonne pour retrouver le tri que je souhaite. Pourrais tu stp faire en sorte que le dernier tri soit sauvegardé et réutilisé après le placement d'une séance ?

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si j'ai cliqué que sur un seul enseignement, VT dit "il y a 1 enseignementS sélectionnéS". Il faudrait enlever les "S" qu'en il n'y en a qu'un.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Il manque une majuscule à "quelle partie faut-il remplacer ?"

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Il manque une majuscule à "par quoi faut-il remplacer ?"

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Quand on va au bout de la procédure, ça ne fonctionne pas. Vt dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons" or il n'y aura pas de doublons avec les modifications que j'ai demandées. L'enseignement que j'ai essayé de modifier se nomme "GMP S1_METHODES_CM" (en majuscule). J'ai demandé de remplacer "methodes" (en minuscule) par "methode" (en minuscule). Chez moi, VT est configuré pour tout écrire en "majuscule" par défaut. Par contre, si je fais une demande de modification en tapant tout en majuscule, ça fonctionne. Il faudrait peut-être ajouter un bouton à cocher pour demander si ça doit être sensible à la casse. Il faudrait aussi considérer que les demandes de modification sont toutes en majuscule quand VT est configuré pour tout écrire en majuscule.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si mon enseignement s'appelle "GMP S1_METHODES_CM" et que je demande de remplacer la chaine "XWK" par "KYZ", VT dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons". Le message d'erreur n'est pas le bon car c'est juste que la chaine demandée n'existe pas dans le nom de mon enseignement.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si je sélectionne 2 enseignements qui se nomment "GMP S1_METHODES_CM" et "GMP S1_MATHS_CM" et que je demande de remplacer la chaine "MATHS" par "MATHEMATIQUES", VT dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons". Suite à ça, aucun changement n'est effectué. Le message d'erreur n'est donc pas le bon. Il faudrait que VT change le nom de l'enseignement pour celui qui contient le mot "MATHS" sans toucher à l'autre enseignement au lieu de ne rien modifier et afficher un message d'erreur qui dit qu'il n'a pu traiter qu'un enseignement sur les 2.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Ca serait bien de faire la même chose pour les alias.

En tout cas, quand ça sera au point ça sera top car ça évitera de passer des heures à corriger les enseignements 1 par 1 quand un il y a une faute de syntaxe.

Merci d'avance et bonne reprise.
Bruno



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1985
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien jeudi 1er septembre 2022 à 23:16  

Ou la la !

Il est déchainé le Bruno !




Bonjour Bruno,


Citation de million :
- Enseignements--> ajouter modifier détruire--> onglet "ressource par défaut", il faudrait renommer le "?" par "Pas de filtre" et griser les cases à cocher.


Si le sélecteur est sur ?, les cases à cocher correspondantes sont rendues inopérandes. Par contre j'ai laissé "?" car si on met "Pas de filtre", ca devient moche. Si on passe la souris sur "?", il y a un texte explicatif qui apparait en bas.

Citation de million :
- Dans Enseignements-->Allocation des ressources aux séances d'un enseignement-->onglet "affectation des ressources"--> onglet "Profs",
les trois lignes du haut du tableau de répartition des séances et la colonne de droite sont vides.
C'est donc un peu compliqué de connaitre les volumes horaires et le nombre de séances affectées à chaque prof.


C'est corrigé.

Citation de million :
- Dans Enseignements-->Allocation des ressources aux séances d'un enseignement-->onglet "affectation des ressources"--> onglets "Salles", "Groupes" et "Matériels", la largeur des colonnes "Libellé","date" et "heure" n'est pas modifiable.


C'est corrigé.

Citation de million :
- Dans Enseignements-->Allocation des ressources aux enseignements-->onglet "allocation des ressources"--> onglets "Profs","Salles", "Groupes" et "Matériels",
la largeur de la colonne enseignement n'est pas modifiable en largeur. C'est un peu dur à lire quand on a des noms un peu longs.


C'est corrigé.

Citation de million :
- Dans groupes--> vue hebdo ou annuelle : après avoir activé l'interrupteur, si je clique sur l'intitulé d'une colonne dans la zone "nb sénaces à placer, la liste des enseignements où il reste des séances à placer se trie bien dans le bon ordre. Ensuite, je place une séances et dès que j'ai placé la séance, VT affiche de nouveau la liste avec le tri initial. Je suis obligé de recliquer sur l'intitulé de la colonne pour retrouver le tri que je souhaite. Pourrais tu stp faire en sorte que le dernier tri soit sauvegardé et réutilisé après le placement d'une séance ?


C'est ajouté.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si j'ai cliqué que sur un seul enseignement, VT dit "il y a 1 enseignementS sélectionnéS". Il faudrait enlever les "S" qu'en il n'y en a qu'un.


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Il manque une majuscule à "quelle partie faut-il remplacer ?"


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Il manque une majuscule à "par quoi faut-il remplacer ?"


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom".
Quand on va au bout de la procédure, ça ne fonctionne pas.
Vt dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons" or il n'y aura pas de doublons avec les modifications que j'ai demandées.
L'enseignement que j'ai essayé de modifier se nomme "GMP S1_METHODES_CM" (en majuscule). J'ai demandé de remplacer "methodes" (en minuscule) par "methode" (en minuscule).
Chez moi, VT est configuré pour tout écrire en "majuscule" par défaut. Par contre, si je fais une demande de modification en tapant tout en majuscule, ça fonctionne.
Il faudrait peut-être ajouter un bouton à cocher pour demander si ça doit être sensible à la casse.
Il faudrait aussi considérer que les demandes de modification sont toutes en majuscule quand VT est configuré pour tout écrire en majuscule.


Si VT est configuré pour tout traiter en majuscules, la partie à modifier et la partie à remplacer sont d'abord convertis en majuscules.
Sinon, VT est nécessairement sensible à la casse (rajouter un bouton à cocher pour cela alourdirait les échanges selon moi).

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si mon enseignement s'appelle "GMP S1_METHODES_CM" et que je demande de remplacer la chaine "XWK" par "KYZ", VT dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons". Le message d'erreur n'est pas le bon car c'est juste que la chaine demandée n'existe pas dans le nom de mon enseignement.


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Si je sélectionne 2 enseignements qui se nomment "GMP S1_METHODES_CM" et "GMP S1_MATHS_CM" et que je demande de remplacer la chaine "MATHS" par "MATHEMATIQUES", VT dit "Les noms ne peuvent pas être changés car cela entrainerait la présence de doublons". Suite à ça, aucun changement n'est effectué. Le message d'erreur n'est donc pas le bon. Il faudrait que VT change le nom de l'enseignement pour celui qui contient le mot "MATHS" sans toucher à l'autre enseignement au lieu de ne rien modifier et afficher un message d'erreur qui dit qu'il n'a pu traiter qu'un enseignement sur les 2.


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du nom". Ca serait bien de faire la même chose pour les alias.


C'est ajouté. smiley s8g29g.gif
L'idéal serait d'étendre ces commandes aux autres fenêtres de définition des ressources (prof, salles, matières, groupes). Je le ferai probablement pour une autre mise à jour.

A noter : lors des remplacements, si plusieurs occurrences sont présentes dans le nom ou l'alias, seule la première est modifiée. Par exemple si on demande à remplacer "A" par "BBB" dans le nom "A A A", on obtient "BBB A A" et non pas "BBB BBB BBB".

Sylvain


J'ai oublié de dire que la version corrigée est ici : http://visual.timetabling.free.fr/MISES-A-JOUR/vt_reseau.exe
Édité 1 fois - Dernière édition: 01/09/2022 à 12:53 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1503
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien samedi 3 septembre 2022 à 10:46  

Bonjour Sylvain

Je viens de tester tes modifications. On est presque bon.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du NOM ou un ALIAS" : A la fin du processus, c'est écrit : "1 changementS ont été réalisés sur". Il faudrait mettre la phrase au singulier quand il n'y a qu'un enseignement. Il faudrait aussi ajouter le chiffre après le "sur".


- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du NOM". Si je fais en sorte de créer un doublon, vt affiche à la fin un message qui indique que le nom ne peut être changé (ça, c'est ok) mais il affiche un deuxième message qui indique qu'il ne peut pas modifier les alias or je n'ai demandé que de changer le nom.

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du ALIAS". Si je fais en sorte de créer un doublon, vt affiche à la fin un message qui indique que l'alias ne peut être changé (ça, c'est ok) mais il affiche une deuxième fois le même message après avoir cliqué sur ok.


- Enseignements--> ajouter modifier détruire--> onglet "ressource par défaut". Le "?" est bien sélectionné par défaut et les les cases sont grisées. Par contre, quand je clique sur "et" ou sur "ou", les cases restent grisées et il faut que je clique sur une case pour qu'elles ne soient plus grisées. Il faudrait que ça ne soit plus grisé dès qu'on clique sur "et" ou "ou".

Bon week-end
Bruno



Visiter son site


 
 
 
 
 
 
Ψsylvain
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1985
Inscrit(e) le: 20 novembre 2004
Imprimer Permalien samedi 3 septembre 2022 à 11:01  


Citation de million :

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du NOM ou un ALIAS" : A la fin du processus, c'est écrit : "1 changementS ont été réalisés sur". Il faudrait mettre la phrase au singulier quand il n'y a qu'un enseignement. Il faudrait aussi ajouter le chiffre après le "sur".


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du NOM". Si je fais en sorte de créer un doublon, vt affiche à la fin un message qui indique que le nom ne peut être changé (ça, c'est ok) mais il affiche un deuxième message qui indique qu'il ne peut pas modifier les alias or je n'ai demandé que de changer le nom.


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du ALIAS". Si je fais en sorte de créer un doublon, vt affiche à la fin un message qui indique que l'alias ne peut être changé (ça, c'est ok) mais il affiche une deuxième fois le même message après avoir cliqué sur ok.


C'est corrigé.

Citation de million :
- Enseignements--> ajouter modifier détruire--> onglet "ressource par défaut". Le "?" est bien sélectionné par défaut et les les cases sont grisées. Par contre, quand je clique sur "et" ou sur "ou", les cases restent grisées et il faut que je clique sur une case pour qu'elles ne soient plus grisées. Il faudrait que ça ne soit plus grisé dès qu'on clique sur "et" ou "ou".


Il manque un rafraichissement. Je vois comment faire.

Je dépose dès que possible.
Édité 1 fois - Dernière édition: 03/09/2022 à 11:03 Par sylvain.


visual timetabler


E-mail Anti-spam


 
 
 
 
 
 
Ψmillion
Administrateur
stars7.png
Dieu Supreme


avatar
Hors ligne

Nombre de posts: 1503
Inscrit(e) le: 1er janvier 2008
Imprimer Permalien samedi 3 septembre 2022 à 12:24  

C'est presque tout bon :

- Enseignements--> ajouter modifier détruire : Clic droit sur un enseignement puis "remplacer une partie du NOM ou un ALIAS" : A la fin du processus, c'est écrit : "Un changement a été réalisé sur". Il manque le chiffre de la fin.

- Avec windows 11, dans le menu du haut de VT, les éléments du menu qui possèdent des icônes sont sur un fond gris qui est plus claire que le reste du menu. Je peux t'envoyer une photo d'écran si tu veux.



Visiter son site


 
 
 
 
Quelques bugs à résoudre  [4 réponses]